最新消息:

帝国cms安装报错Deprecated: Function get_magic_quotes_gpc()

编程 eben 84浏览 0评论

随着近期dedecms的发布的版权收费公告开始,很多站长都开始在迁移数据到别的cms。9月的时候,在dedecms的官网上发现几年不更新的dedecms居然开始对程序进行了升级,正准备下载下来测试的,后续就出现了dedecms发布的公告事件,后来陆续看了几个cms,但是都不太理想,近日准备开始研究帝国cms,但是在本地安装好之后居然报错了。

错误提示:Deprecated: Function get_magic_quotes_gpc() is deprecated in D:\phpstudy_pro\WWW\www.xxxx.com\e\class\connect.php on line 6

错误提示截图:

错误的位置在connect.php文件的第六行,这个错误的原因是PHP 7.4不推荐使用get_magic_quotes_gpc函数替代(PHP 7.4 deprecated get_magic_quotes_gpc function alternative)。

错误解决办法:

将第六行的代码:

define('MAGIC_QUOTES_GPC',function_exists('get_magic_quotes_gpc')&&get_magic_quotes_gpc());
PHP

改为:

define('MAGIC_QUOTES_GPC',ini_set("magic_quotes_runtime",0)?True:False);
PHP

再次刷新帝国cms发现错误信息已经消除。

转载请注明:落伍老站长 » 帝国cms安装报错Deprecated: Function get_magic_quotes_gpc()

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址