最新消息:

个人使用wordpress制作各类资料站必备的插件

站长 eben 75浏览 0评论

我经常要制作各种资料站,也就是传说中1IP那种资料站

通常情况下呢,应该是使用火车采集器这种工具来制作

原因很简单,很多的目标站都设置了防盗链,我们无法下载他们的图片,所以需要第三方的采集器来下载

下载图片之后可以批量上传到某个静态空间,就是维护起来麻烦一点

闲话少谈,我们直接进入正题,就是我都使用了那些wordpress插件

Classic Widgets

【经典小工具】启用外观-小工具和定制器中的经典小工具设置页面,并禁止使用区块编辑器管理小工具。

Enlighter-可自定义的语法高亮插件

多合一语法高亮解决方案4.5.0版本 | 作者:Andi Dittrich

IMGspider

IMGspider(图片蜘蛛)是一款用于WordPress文章图片抓取的WordPress插件,支持JPG, JPEG, PNG, GIF, BMP, TIF等常见图片爬取下载,实现一键抓取文章内容所有引用图片到本地服务器。VIP版本似乎99元一个域名,适合一个wp站点当做中心站,为其他站点提供图片

2.3.5版本 | 作者:wbolt team

Redis 对象缓存

A persistent object cache backend powered by Redis. Supports Predis, PhpRedis, Relay, replication, sentinels, clustering and WP-CLI.

2.2.2版本 | 作者:Till Krüss 

适合大一点站点,比如访问量特别大的站点,单独使用一台VPS,或者多台VPS的情况

简易目录

添加用户友好且全自动的方式来创建和显示从页面内容生成的目录。

2.0.40版本 | 作者:Magazine3 

经典编辑器

启用 WordPress 经典编辑器和旧式的编辑文章页面,包括 TinyMCE、Meta Boxes 等。支持扩展此页面的旧插件。

1.6.2版本 | 作者:WordPress 贡献者
这个也不是必须,如果大家习惯了新版的古腾堡编辑器,不使用这个也可以

wp-jquery-lightbox

A drop in replacement for LightBox-2 and similar plugins. Uses jQuery to save you from the JS-library mess in your header. 🙂

Remove Category URL

This plugin removes ‘/category’ from your category permalinks. (e.g. `/category/my-category/` to `/my-category/`)

1.1.6版本 | 作者:Valerio Souza, Сreativemotion
这个算是网站seo优化范畴的,去掉伪静态中目录前缀

Advanced Editor Tools

Advanced Editor Tools (previously TinyMCE Advanced)

作者:Automattic

Advanced Editor Tools (previously TinyMCE Advanced) introduces a “Classic Paragraph” block for the block editor (Gutenberg).
If you are not quite ready to switch to the block editor, or have plugins that cannot be used there (yet), using the Classic Paragraph block is your best option. It lets you to continue to use the familiar TinyMCE editor for most tasks, and at the same time gives you full access to all blocks and new features in the block editor.

Version 5.5 continues to improve and enhance the new features introduced in version 5.0 of the plugin. It includes an improved “Clear Formatting” button, several advanced settings for tables, and importing and exporting of the settings to a file.

If you want to continue to use the previous (“classic”) editor in WordPress 5.0 and newer, this plugin has an option to replace the new editor with the previous one. If you prefer to have access to both editors side by side or to allow your users to switch editors, it would be better to install the Classic Editor plugin. Advanced Editor Tools is fully compatible with the classic editor plugin and similar plugins that restore use of the previous WordPress editor.

As always this plugin will let you add, remove and arrange the buttons that are shown on the Visual Editor toolbar in the Classic Paragraph and Classic blocks in the block editor, and in the classic editor (when enabled by a plugin). There you can configure up to four rows of buttons including Font Sizes, Font Family, text and background colors, tables, etc.

It includes 15 plugins for TinyMCE that are automatically enabled or disabled depending on the buttons you have chosen.
In addition this plugin adds options for keeping the paragraph tags in text mode and importing the CSS classes from the theme’s editor-style.css.

Some of the features added by this plugin

  • “Classic Paragraph” block that can be used instead of or together with the standard Paragraph block.
  • An option to set the Classic Paragraph or Classic block as the default block in the block editor.
  • Supports converting of most default blocks to classic paragraphs, and from classic paragraphs back to the default blocks.
  • Support for creating and editing tables in the Classic blocks and the classic editor.
  • More options when inserting lists in the Classic blocks and the classic editor.
  • Search and Replace in the Classic blocks and the classic editor.
  • Ability to set Font Family and Font Sizes in the Classic blocks and the classic editor.
  • And many others.
Privacy

Advanced Editor Tools does not collect or store any user related data. It does not set cookies, and it does not connect to any third-party websites. It only uses functionality that is available in WordPress, and in the TinyMCE editor.

In that terms Advanced Editor Tools does not affect your website’s user privacy in any way.

转载请注明:落伍老站长 » 个人使用wordpress制作各类资料站必备的插件

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址